Ford Shelby GT500 Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Has anyone experienced a problem where the engine does not return to idle when you let off the gas? I had this happen today and scared the heck out of me. I had just taken off from a stop light and was in 1st gear at about 3k RPMs, but was not really flooring it when another car pulled out in front of me. I let off the gas and hit the brakes, but the car did not drop to idle right away. It took about a second (long second) for the RPMs to drop to idle.

If this is a known problem, what is the fix? Thanks for the help.
 

·
Registered
Joined
·
170 Posts
You're car is a drive by wire so there is no throttle cable You need to get this car to the dealer to have them look at it.
 

·
Premium Member
Joined
·
11,063 Posts
Has anyone experienced a problem where the engine does not return to idle when you let off the gas? I had this happen today and scared the heck out of me. I had just taken off from a stop light and was in 1st gear at about 3k RPMs, but was not really flooring it when another car pulled out in front of me. I let off the gas and hit the brakes, but the car did not drop to idle right away. It took about a second (long second) for the RPMs to drop to idle.

If this is a known problem, what is the fix? Thanks for the help.
If you have an aftermarket tune in it just reload it. If it's stock, did you have a significant weather change the day it happened?

When you start your car, let it idle for no less than 30 seconds, preferably a full minute. If you still have the problem, see the doctor/mechanic.

Quick weather changes do in fact make a difference.

bj
 

·
Registered
Joined
·
38 Posts
Has anyone experienced a problem where the engine does not return to idle when you let off the gas? I had this happen today and scared the heck out of me. I had just taken off from a stop light and was in 1st gear at about 3k RPMs, but was not really flooring it when another car pulled out in front of me. I let off the gas and hit the brakes, but the car did not drop to idle right away. It took about a second (long second) for the RPMs to drop to idle.

If this is a known problem, what is the fix? Thanks for the help.
I had a throttle stick in a Lexus. Immediate limp home mode was intiated. Warmed it up, and it never happened again (although I had to reset computer with a battert disconnect). It was -10 degF and I assume it froze up.
 

·
Registered
Joined
·
240 Posts
Do you have an aftermarket TB on the car? I had problems with my initial KB TB. Sent it back to them and they corrected the issue.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
No after-market TB or tune. Stock except for Corsa cat-back and FRPP shifter. I'm going to make an appointment for this week.
 

·
Registered
Joined
·
4 Posts
I just had the same thing happen with my 2011 GT500. All stock no mods. I turned off traction control to do a small burn out and when I released the gas pedal it continues to rev for about 1 second. Scared the heck out of me because one month ago I got a 454SS pickup back from the race shop with a 496 build out and a FAST fuel system and on the first drive where I nailed it the throttle stuck wide open and accelerated my to over 80 MPH with both front wheels locked up. After 100 yards of dual black marks from the front wheels as measured by the cops, I had to intentionally hit a fire hydrant to shut it down and avoid being pushed into a 4 way intersection. I am having flash backs. Any news on this sticking situation?
 

·
Premium Member
Joined
·
2,203 Posts
I just had the same thing happen with my 2011 GT500. All stock no mods. I turned off traction control to do a small burn out and when I released the gas pedal it continues to rev for about 1 second. Scared the heck out of me because one month ago I got a 454SS pickup back from the race shop with a 496 build out and a FAST fuel system and on the first drive where I nailed it the throttle stuck wide open and accelerated my to over 80 MPH with both front wheels locked up. After 100 yards of dual black marks from the front wheels as measured by the cops, I had to intentionally hit a fire hydrant to shut it down and avoid being pushed into a 4 way intersection. I am having flash backs. Any news on this sticking situation?
why didn't you just turn it off? or go to nuetral instead of the fire hydrant- I think the tranny would be cheaper than the hydrant and labor, glad your ok though.
 

·
Premium Member
Joined
·
11,063 Posts
I just had the same thing happen with my 2011 GT500. All stock no mods. I turned off traction control to do a small burn out and when I released the gas pedal it continues to rev for about 1 second. Scared the heck out of me because one month ago I got a 454SS pickup back from the race shop with a 496 build out and a FAST fuel system and on the first drive where I nailed it the throttle stuck wide open and accelerated my to over 80 MPH with both front wheels locked up. After 100 yards of dual black marks from the front wheels as measured by the cops, I had to intentionally hit a fire hydrant to shut it down and avoid being pushed into a 4 way intersection. I am having flash backs. Any news on this sticking situation?
Make sure your floormat wasn't the issue. It happens.

bj
 

·
Registered
Joined
·
4 Posts
why didn't you just turn it off? or go to nuetral instead of the fire hydrant- I think the tranny would be cheaper than the hydrant and labor, glad your ok though.
I get asked a lot about the killing the switch or shifting the tranny rather than hitting the fire hydrant and the answer is that this was the second time I drove the truck (first to the shop for the engine build) and I wasn't used to the key position or having a column shift auto so in the panic I could think through it. BTW after hitting the hydrant, I was at least expecting to see a major water gush because deep inside a lot of us have always wanted to knock one over to see the spray, but in Austin, they have safety valves and break away bolts so I saw nothing. Bummer.
 

·
Registered
Joined
·
4 Posts
You are talking about my GT500, I checked it the floor mat was clear. If you are talking about truck, it turns out that the new Edlebrock air cleaner the shop picked and installed was installed with a low rise base by mistake (not needed since the truck had a cowl hood with lots of clearance) which caused the throttle linkage, when fully depressed, to jam up against the base and stick. That's why I never had to turn it in to my insurance the shop is completely rebuilding the truck better than new on their own dime. For some reason they didn't want to have to explain to a Texas judge almost killing two people with an improper equipment install and then not making things right :)
 

·
Premium Member
Joined
·
11,063 Posts
Oopsie! Yeah, smart move. Yes...talking about your GT500. Honestly I've seen a half dozen of them with the mat hitting the accel. Since it's really more of an electrical device than a conventional gas pedal, they're a little more prone to it.

bj
 

·
Premium Member
Joined
·
2,203 Posts
I get asked a lot about the killing the switch or shifting the tranny rather than hitting the fire hydrant and the answer is that this was the second time I drove the truck (first to the shop for the engine build) and I wasn't used to the key position or having a column shift auto so in the panic I could think through it. BTW after hitting the hydrant, I was at least expecting to see a major water gush because deep inside a lot of us have always wanted to knock one over to see the spray, but in Austin, they have safety valves and break away bolts so I saw nothing. Bummer.
Funny story my first car 74 charger that I restored and put on the road at 16yr old had the throttle stick do to a linkage bind, and I too ran it up to about 90mph and spun the car out and took out a few traffic signs. Long story short the cops came out and chewed my ass, and gave me the "why didn't you just turn it off", so my response yesterday was a chance to pay it forward from 25 years ago..ha ha. Glad your ok, and the truck sounds like a real monster too!
 
1 - 13 of 13 Posts
Top