Ford Shelby GT500 Forum banner

1 - 20 of 54 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
When I go over speed bumps slowly, the shocks sound like they are loose; does anyone else get the same thing?
 

·
Registered
Joined
·
662 Posts
No noise here.:bananahump-slvrathl
 

·
Registered
Joined
·
373 Posts
Not in the Shelby =/
but in the Jeep. yepper.

Is the car stock? Have you done any suspension work at all?
 

·
Registered
Joined
·
38 Posts
When I go over speed bumps slowly, the shocks sound like they are loose; does anyone else get the same thing?
Mine makes a thuddy noise on every expansion joint, bump, etc.. up to speeds of about 40mph. Then you can't hear it. It is like a double hit, like the sound at first impact, then as the part comes back, it does it again. Thud-Thud.....Thud-Thud.... It sounds like the damn front end is going to fall off, at least to me.

It sounds like something is lose and you can feel it in the floor and brake pedal, etc...

The dealer ordered 2 struts and strut mount plates, which are to be in soon, and installed next week. I really hope this goes away.

At least the dealer agrees that something is wrong with the car. That part has taken two attempts.

Something in our cars must have a QC issue....
 

·
Registered
Joined
·
20 Posts
I have the same sound and its been to the dealer once... They changed a sway bar end link and thought that fixed it, but it did not. Will be good to hear if the Struts and Plates fix it.. It will give me someting to run at them with...I have a 08 with 3000 miles on it....
 

·
Registered
Joined
·
38 Posts
I have the same sound and its been to the dealer once... They changed a sway bar end link and thought that fixed it, but it did not. Will be good to hear if the Struts and Plates fix it.. It will give me someting to run at them with...I have a 08 with 3000 miles on it....
Mine is an '08 with 2000 miles on it, but it did it right off the lot with 8 on it.

I worry about how much damage will happen too it, but I can't live with the noise. It drives me nuts.

It is supposed to go in this week, so I'll bive feedeback after I get it back.
 

·
Registered
Joined
·
38 Posts
When I go over speed bumps slowly, the shocks sound like they are loose; does anyone else get the same thing?
I had my strut mounts and struts replaced. It is 90% better. Only on about 10% of the impacts it used to make noise, it still does.

This makes me wonder what level is normal. Some people say that they never hear any noise, yet I now have the major parts of the front end changed, and it definitly made a huge improvement, yet left a bit of what I call noise on big impacts.

Since mine got 90% better, I have to assume that the parts replaced were the culprits, unless I have multiple problems, which seems very unlikely. Since they were completely replaced with new, I have to assume some variance is normal in these parts and I now have some that were 90% tighter than the first set.

Since I have no basis, I am going to convince myself that what my car now does is normal, and see if it gets worse over time.

If I didn't point it out to a rider, with the replaced parts, they would never notice it. Prior to replacement, many people asked what was wrong with it, it was so bad....
 

·
Registered
Joined
·
15 Posts
What kind of struts and what was the cost. I also have had the same noise since new I have changed strut mounts and didn't help.
 

·
Registered
Joined
·
38 Posts
What kind of struts and what was the cost. I also have had the same noise since new I have changed strut mounts and didn't help.
Stock Ford stuff. Warranty....

I have decided it needs more work, however, since it still makes thudy noises at 10mph and under. As I pull up to stop signs, etc... and hit expansion joints, etc... it makes noises I am certain can't be normal.

Dealer is working on a fix and I hope to have more work done next week....

I was trying to convince myself that it was fixed and normal, but everytime I drive it, I hear banging that no other car I have ever owned has done. Can't be normal, so back we go....
 

·
Registered
Joined
·
15 Posts
Sveet, keep me posted my dealer will not work with me since I have put Eibach Pro Kit springs on. I have had the car to every mechanic I can find and they have done things like lubed all the bushings and tightened everything to torque spec. Still makes the same noise the car has 4000 miles now i just wish i knew what it was.I know exactly what you mean about driving you crazy. I have put a lot of money in this car i know i could never get backlet me know what it is when you get it straightened out. Thanks
 

·
Registered
Joined
·
38 Posts
Sveet, keep me posted my dealer will not work with me since I have put Eibach Pro Kit springs on. I have had the car to every mechanic I can find and they have done things like lubed all the bushings and tightened everything to torque spec. Still makes the same noise the car has 4000 miles now i just wish i knew what it was.I know exactly what you mean about driving you crazy. I have put a lot of money in this car i know i could never get backlet me know what it is when you get it straightened out. Thanks
I will let you know. It seems like this is a rare problem, but yet it isn't just one car.

The strange thing is I was pretty convinced that it was either the struts or the strut mounts, and since both were replaced, it did infact get better, but not go away.

Since most people seem to not have this problem at all, what are the chances I'd get a bad component on the replacement? Seems low... So then what is making the noise now? It seems like the same noise as before, just less of the time / takes bigger hits now. Still the noise, however.

I can only think it is the strut mount, swaybar link, some ball joint, or steering rack bushings, etc...

I really hope that they figure this out.
 

·
Registered
Joined
·
38 Posts
No good progress yet. I still think that my car is making more front end impact noise than it should, but I think the next step is going to be to compare it to another GT500 Convertible. I think we / I need to do this to decide if I still have a problem. I think the front end is making more noise than it should, the dealer also hears the noise, it is just now that we are all wondering what a "normal" level of noise is? At times I drive it and conclude no way can this be "normal", then other times I convince myself maybe it is "normal". This may drive me mad.....
 

·
Premium Member
2008 Vapor/Black Coupe
Joined
·
1,951 Posts
I'm not sure what noise you're hearing, but I've seen on a few of the suspension sites that on the lowered cars tend to have the popping noise unless you put in heavy duty strut mounts. Our strut mounts are weak, so it is likely that if you hit a lot of bumps or big bumps you have problems with the stock mounts. Off of steeda's website,

"These upper mounts eliminate the "popping" sound that is common on lowered cars when the factory upper mount fails. Unlike the factory piece, you can also get an extra 1 degree of camber in each direction with these plates as well. Steeda's heavy duty upper mounts are specifically designed for street use and will not show any increase in NVH when installed.Price includes a set of two."

Since the dealer acknowledges the problem, you may be able to get them to put the in for free...good luck.
 

·
Registered
Joined
·
38 Posts
I'm not sure what noise you're hearing, but I've seen on a few of the suspension sites that on the lowered cars tend to have the popping noise unless you put in heavy duty strut mounts. Our strut mounts are weak, so it is likely that if you hit a lot of bumps or big bumps you have problems with the stock mounts. Off of steeda's website,

"These upper mounts eliminate the "popping" sound that is common on lowered cars when the factory upper mount fails. Unlike the factory piece, you can also get an extra 1 degree of camber in each direction with these plates as well. Steeda's heavy duty upper mounts are specifically designed for street use and will not show any increase in NVH when installed.Price includes a set of two."

Since the dealer acknowledges the problem, you may be able to get them to put the in for free...good luck.
I already had a complete set of struts and strut mounts replaced and it changed, but didn't eliminate the noise. Another pair of new struts and strut mounts are going in later this week.

My car is 100% stock and the noise has been present from the first miles, so wear can't be it.

The sway bar was removed and the noise was still present, so it is not related to the sway bar or the end links.

I suspect it is strut mounts, but why I had a bad pair from the factory, and then another bad pair on the first attempt, I have no idea. I really really really cross my fingers and hope that thes next set does the trick.
 

·
Registered
Joined
·
2,466 Posts
I actually just started getting a noise that seem might be shock-related. At low speeds (under 30 mph), when I hit small, sharp bumps in the road (like manhole covers or cracks) and get a clunk in the front left.

I jacked up the car to check it out. If I grab the tire with one hand on the front of the tire and one on the back and yank on it hard, pushing in on the front and pulling back on the back, hear the clunk. It sounds like it's coming from the area of the upper part of the shock, but it's hard to tell.

If I do the opposite (pull on the front and push on the back) I don't hear the clunk.
 

·
Registered
Joined
·
15 Posts
I have already put the HD Steeda Upper Strut mounts in and it did not change anything and also checked endlinks and removed sway bar and the noise was still present. Anyone that knows a fix Please Help.
 
1 - 20 of 54 Posts
Top