Ford Shelby GT500 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
301 Posts
Discussion Starter #1
Guys, I was going to clean brake dust from inside wheels tonite. Jacked car up and put stands under it. Crawled under and noticed that lower radiator valance had two bolts that had pulled clip nuts out of front crossover. Removed the only one that was still intact and finished dropping down for a look see. It had in fact pulled the two mounting nuts out. This valance does have a hook on each end that goes in to crossover as well to help suspend this piece. removed bolts from valance 7/32 if I remember correctly, nuts were still attached tightly to valance. I attempted to straighten, just so I could reattache until I can get a couple from dealer. You might want to check yours. These bolts hold just the rear of valance it is not going to fall out, but it sure can be flopping in the wind, especially if you lose all 3.

This piece is well underneath directly behind the lower front spoiler that we are banging all the time. Lying under the vehicle you will see w/shield washer btl directly to your right. Hope this helps.

ILLEGAL
 

·
Registered
Joined
·
2,400 Posts
Illegal, mine were not attached properly at the factory and I corrected the problem back in September when I had radiator hose leaks.
 

·
Registered
Joined
·
301 Posts
Discussion Starter #3
shlbysvt

I got with my dealer today. They ordered me 3 new press in nuts. I believe that what I done would be sufficient, but aI will put nuts in storage, just in case.

ILLEGAL
 
1 - 3 of 3 Posts
Top