Ford Shelby GT500 Forum banner

81 - 100 of 111 Posts

·
Registered
Joined
·
2,902 Posts
A vacuum leak or unmetered air after your MAF sensor.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
402 Posts
Discussion Starter #82
Intake boot popped off. Got that fixed and now she’s being pissy again.

Developed a bad miss on the freeway, got off the freeway and at that point power was way down. Idle was horrible etc.

Went to Record my idle sound and when I got to the back of the car. It went back to idling perfect. At that point it was late and I threw it in the garage.

Been working the past 2 weeks in CA and haven’t touched it.

I plan to buy new spark plugs when I get back and go from there.


Sent from my iPhone using Tapatalk
 

·
Super Moderator
Joined
·
5,523 Posts
Intake boot popped off. Got that fixed and now she’s being pissy again.

Developed a bad miss on the freeway, got off the freeway and at that point power was way down. Idle was horrible etc.

Went to Record my idle sound and when I got to the back of the car. It went back to idling perfect. At that point it was late and I threw it in the garage.

Been working the past 2 weeks in CA and haven’t touched it.

I plan to buy new spark plugs when I get back and go from there.


Sent from my iPhone using Tapatalk
Ah, man, sorry for your troubles. Stick with it, you'll get it nailed down! :grin:
 

·
Premium Member
Joined
·
8,354 Posts
Intake boot popped off. Got that fixed and now she’s being pissy again.

Developed a bad miss on the freeway, got off the freeway and at that point power was way down. Idle was horrible etc.


Had a similar experience in my stock 2008 GT500. It was running fine on a cruise, came back into town and I thought I felt a few misfires, pulled up to a stoplight and she flat died, luckily she SLOWLY cranked back up and I drove it straight home. With the SLOW crank, I decided the old factory battery was going bad, so I put in a new battery and never had a problem after that. These cars seem overly sensitive to poor battery performance. Just an FYI and something you might check into. Best of luck getting your beast back on the road …. they are fun and smooth cars to run down the highway at elevated speeds !! :)
 

·
Moderator/Admin Dude!
2020 CFTP Red! 2011 Kona Blue
Joined
·
36,300 Posts
These cars do not like unmetered air getting into the engine (air not going by the MAF sensor). After you put it back together, you could have pulled the negative battery cable to clear the PCM’s adaptive memory. How well the car would run then would depend on how exact your tune is, but the computer would start adapting to your setup with all of your connections secured.
 

·
Registered
Joined
·
402 Posts
Discussion Starter #86
These cars do not like unmetered air getting into the engine (air not going by the MAF sensor). After you put it back together, you could have pulled the negative battery cable to clear the PCM’s adaptive memory. How well the car would run then would depend on how exact your tune is, but the computer would start adapting to your setup with all of your connections secured.


Thanks for the info sir, as for tuning, I’m still on a test file from VMP, need to send them an rev/idle log for them to make me a tune. It just been one of those times in life where I’ve been putting it on the back burner.

I’m pretty sure I probably killed the plugs faster being on the test tune.


I’ll try to disconnect the battery and go from there.


Thanks Goose!!


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
402 Posts
Discussion Starter #87
Got new spark plugs going in. What’s the best gap for this car? .28??

It’s got the normal stuff, 123intake, VMP 67mm TB, pulley


Thanks!
Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
402 Posts
Discussion Starter #88
So it seems to be fixed. Haven’t done a Hwy run yet but drove it to Breakfast.

Runs way better... spark plugs were the culprit.

So what would cause this? I am running on a test tune still so I’m leaning towards that.




Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
402 Posts
Discussion Starter #93
So finally got the Mechman Alternator installed. No pictures, Ford did the install (my friend is. Master tech there). Picked it up at 1pm Saturday drove straight to a wedding. Got back to my family’s home at 2 am and left back to CA Sunday at noon. Didn’t even open the hood to see the upgraded power cables lol..

As for the mechman. I was a bit let down. For the price I paid. I’d expect perfection. They don’t have the cable connection on the back end in the same area. Factory is 6 o clock and the mechman was 3:30. My buddy had to stretch the factory cable to Connect back into the connector. When we asked mechman. They responded by saying we never heard about this, and try to unstrap the factory cable wherever it’s strapped down to stretch it to fit.......

Car is running great other wise. Just need to fix the dreaded door panel leather unpeeling.


Sent from my iPhone using Tapatalk
 

·
Premium Member
Joined
·
11,063 Posts
So finally got the Mechman Alternator installed. No pictures, Ford did the install (my friend is. Master tech there). Picked it up at 1pm Saturday drove straight to a wedding. Got back to my family’s home at 2 am and left back to CA Sunday at noon. Didn’t even open the hood to see the upgraded power cables lol..

As for the mechman. I was a bit let down. For the price I paid. I’d expect perfection. They don’t have the cable connection on the back end in the same area. Factory is 6 o clock and the mechman was 3:30. My buddy had to stretch the factory cable to Connect back into the connector. When we asked mechman. They responded by saying we never heard about this, and try to unstrap the factory cable wherever it’s strapped down to stretch it to fit.......

Car is running great other wise. Just need to fix the dreaded door panel leather unpeeling.


Sent from my iPhone using Tapatalk
They've heard of it. I told them.

Sent from my SM-N950U using Tapatalk
 

·
#1 Mike!
2019 Shelby GT350
Joined
·
10,088 Posts
It's easier to lie than to tell the truth. You can bet BJ let them know of the issue in clear and precise King's English! He's not one to dance around the maypoll!
 

·
Registered
Joined
·
402 Posts
Discussion Starter #98
Holy smokes, it’s been almost a year. Car has 28k miles.

It’s going to be my DD again for a while. Took a trip to he Hollywood sign today.




Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
402 Posts
Discussion Starter #99
Car is now at 30k, dumped some money into it.

-BMR relocation brackets

-eibach Adjustable LCA.

BMR adjustable Track bar/track bar Brace

-BMR adjustable UCA and bracket

-Powerslot rotors/Hawks HPS pads

-morimoto LED fog lights/Headlights

-smoked turn signals lens and side markers

-BMR driveshaft loop

- JLT catch can










Car handles way better. My only issue is the creaking noise from under the rear seat, like the body is flexing. I’m thinking it’s the poly bushing from the UCA? Is that normal?



Sent from my iPhone using Tapatalk
 

·
Premium Member
2013 Shelby GT500 performance white
Joined
·
834 Posts
I had a new BMR upper control arm put on and the bushing was bad from the factory. Made all kinds of noise. Replaced with new upper control arm now no noise.
 
81 - 100 of 111 Posts
Top