Ford Shelby GT500 Forum banner

1 - 13 of 13 Posts

·
Premium Member
Joined
·
865 Posts
Discussion Starter #1
I still have alot of "clunking" goin on in the rear suspension after installing BMR LCAs and a J&M UCA(with anti-clunk washers). I have torqued and retorqued all bolts. Will J&M UCA mount help solve this problem?
 

·
Registered
Joined
·
2,466 Posts
I have a lot of clunking as well: BMR UCA and Evo LCAs. So far I haven't found any solutions.
 

·
Registered
Joined
·
180 Posts
I have a lot of clunking as well: BMR UCA and Evo LCAs. So far I haven't found any solutions.
Did you get the anti-clunk bushing installed with your upper?

I have no clunking with CHE uppers and lower, you need to be carefull install those bushing as they are easy to misplace and just crush them!
 

·
Registered
Joined
·
7 Posts
I have the BMR UCA and I have not been able to get rid of the clunk. I bought a J&M to replace it. Hopefully it will be better.
 

·
Registered
Joined
·
2,400 Posts
BMR adjustable UCA & mount, Evo LCA and no issues here.
 

·
Registered
Joined
·
2,466 Posts
Do you have an after market UCA mount?
Yes, I do. I think it's a BMR mount? It's whatever came with Evolution's ultimate lowering package.
 

·
Registered
Joined
·
2,400 Posts
So changing out the mount proly won't help get rid of the clunk, cause that is a b_tch to chage I heard.
Not at all! The mount just requires removing the rear seat, not an issue, and lowering one side of the gas tank mount. Want a b_tch install, try headers.
 

·
Registered
Joined
·
429 Posts
i have J&M upper control and i have no clunk
 

·
Registered
Joined
·
233 Posts
I have the J&M LCAs(no Relo), and UCA. Vogtland Sport springs, with original Tokico shocks. I do get a bit of clunking, but was told by the folks who did the installs, and I believe them, it goes with the rigging... ;)
 
1 - 13 of 13 Posts
Top