Ford Shelby GT500 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1,016 Posts
Discussion Starter #1
My car arrived at the dealership yesterday. I'll be picking her up on Monday. Here are a few quick shots. More to follow.

9-23 001.jpg
9-23-002.jpg
9-23 003.jpg
9-23 004.jpg
 

·
Registered
Joined
·
171 Posts
Looks great! I changed my original order from the white w/blue stripes to the alloy with top stripe delete like yours except mine is a coupe. It's really hard to get a feel for the color, but I wanted something non-discript and that would really shine with a good finish. Can you describe the color?
 

·
Registered
Joined
·
1,016 Posts
Discussion Starter #5 (Edited)
Looks great! I changed my original order from the white w/blue stripes to the alloy with top stripe delete like yours except mine is a coupe. It's really hard to get a feel for the color, but I wanted something non-discript and that would really shine with a good finish. Can you describe the color?
I'm very happy with the color. It's dark, but not as stark (some might say not as mean) as Ebony. The side mirrors, hood vents, and lower fascia seem to blend in with it nicely. I'm not letting the dealer do any washing/waxing. I'll get it home and clay bar it either Monday or Tuesday. I think it will really shine up nicely.

I've used Zaino in the past, with good results. But it seemed to be more work than it should have been. I've also used Adam's polishes, with similar results as Zaino. Adam's seems to be a little easier to me. I know Zaino-philes are passionate about that product, and I'm not looking to get into a debate. That was my experience, but I haven't decided which way to go yet.

Back to the color, I'm very pleased with how subtle the Tungsten side stripes are. I think that combo might be the least in terms of contrast.

I also opted for the crimson inserts in the seats. I didn't take any interior shots yet, as the plastic was still on the seats.

I didn't mention it in the first post, but I did get to put 22 miles on it yesterday. This car is fun to drive. I didn't notice the clutch chatter that others have mentioned. I did hear the SC whine about 7 miles into my trip, which prompted me to check the boost gauge. 8 psi, so the SC did come online like advertised after +/- 5 miles of continuous driving. I also did turn off the TCS to transfer some rubber to the asphalt once. I had to take it a little easy, though, as my 5 year old daughter was in the back seat.

I'm taking Monday off (maybe Tuesday, too, depending on the weather) to observe the PDI process, watch some parts go on, and drive it a little all by myself. I figure I'll put 300 to 400 miles on it in that time.
 
1 - 5 of 5 Posts
Top